More Ramblings from a Los Angeles Programmer

April 9, 2008

Strange keyboard issue

Filed under: daily life, technology — Tags: , , , — Josh DeWald @ 3:19 pm

I have been having this issue for over a year now, and have not been able to find a solution via Google nor through company IT (not for lack of trying on their part, it’s a whacky issue).

Very often (but it can also go for weeks) some of my keys will stop working on my Dell Latitude D610. It is generally the same keys, and will even occur in similar orders after reboot. The “favored” keys are: r,1,e,=,and ESC. Sometimes ‘o‘ and ‘y‘ won’t work. Even better, there are times when the ‘m’ key will actually output a ‘,’.

I need help!

It is very unlikely that it is either the keyboard or the actual laptop as we have tried:

  1. Using external keyboard (the exact same keys will not work)
  2. Replacing the laptop keyboard from another one
  3. Replacing the entire laptop itself (moving the hard drive to another)
  4. Running full system checks from IT department to check for viruses, corrupt files, etc (everything checks out)

So, to me, this would imply that it’s a driver problem in Windows. I have no attempted to replicate the issue in another Operating System. I don’t work in Linux enough (at all) on this machine to be able to sit around until it happens.

Most answers on the internet blame the keyboard, but based on the evidence I do not see that as being it at all.

I have recently downloaded a keyboard test application to see if anything is being detected when I hit the keys in question during one of these incidents.

Anyhow, hoping my few readers perhaps have an idea or have seen similar issues.

Update (4/22/2008): So a couple of days I had this issue again but I really wanted to be able to get logged in so I went through each of my keys to see what would happen. It definitely was like some bit was getting forced to be set or some wiring issue (and still I’m convinced that’s not it). For instance, the ‘m’ key was outputting a ‘c’ I think. I finally tracked down the ‘m’ key by hitting the RIGHT SHIFT key (not the left). I had downloaded a “keyboard test” program and when I ran that there weren’t any actual discrepancies (which is what I was hoping for):when I hit ‘m’, it output the same results for both the BIOS read and the Windows read.

Blog at WordPress.com.